Results 1 to 2 of 2

Thread: Electrical

  1. #1
    Join Date
    Jun 2021
    Posts
    1

    Default Electrical

    My 2003 50th anniversary edition Corvette, with only 18,000 miles, lost all instrumentation. I took it to the local Chevrolet dealer and they diagnosed a failed instrument cluster. They sent off to be rebuilt and when I got the car back, the display lights for the radio, AC, and message box where the odometer reading is were all dim when the headlights are off and bright when the headlights are on, which I believed to be the opposite of what they should do. The dealer mechanic told me that it could not be the instrument cluster because those display lights don't go through the instrument cluster but come directly off of the body control module. So I bought a remanufactured body control module. They installed it and said everything was now fine. When I picked up the car, the display lights were still doing the same thing and now all of the program buttons do not work. I went back inside the dealership and told the mechanic that nothing was fixed and now the program buttons do nothing. Without even checking anything, he said that the remanufactured body control module had to be defective. I had an independent mechanic put the old body control module back in and the program buttons still don't work. So he put the remanufactured body control module back in and told me to take it back the Chevrolet dealer and tell them that the independent mechanic put an analyzer on the car and based on what it said and what I told him had happened, he thinks that the program button problem is not related to the body control module and that the program buttons were somehow deprogrammed and needed to be reprogrammed. The independent mechanic had no answer for the display problem other than he thinks that the instrument cluster is the problem. He thought that it would make no sense for the display lights to bypass the instrument cluster and run directly off of the body control module. I have another appointment with the dealership on Wednesday, June 9 and I would like to have a basis for disputing what he may tell me next. Could the instrument cluster cause the display light problem? And what would cause the program buttons to no longer work?

  2. #2
    Join Date
    Nov 2019
    Location
    Cape Coral, Florida
    Posts
    11

    Default

    Even without looking at service information I'd say lighting for the IPC doesn't come through the BCM...Sounds like a possible bad ground or power as far as the lighting and possibly the buttons go...Someone needs to remove the IPC and check power and grounds and also pin fitment at the IPC connector. If you had some grounding issues initially a new IPC isn't going to fix it !!...ground for the IPC is G104 but it goes through SP208 first !!
    Last edited by C5 Diag; 06-08-2021 at 01:10 PM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •