Results 1 to 3 of 3

Thread: Having a few problems with my 2000 m6 c5

  1. #1
    Join Date
    Mar 2021
    Posts
    1

    Default Having a few problems with my 2000 m6 c5

    So I just bought this car few weeks ago, now all of a sudden I have no tachometer, light buckets won't come up and if I manually make them the lights don't work but if I put on hight beam you see the lights flash on for a second. There is a flutter with the interior lighting and with the buttons beside mycluster. So I just wondering if this could all be linked or separate issues. The battery was replaced the day I got it by previous owner. Any help appreciated

  2. #2
    Join Date
    Jul 2016
    Posts
    21

    Default

    Boy, sounds like a loose ground somewhere

    Sent from my SM-G988U using Tapatalk

  3. #3
    Join Date
    Dec 2011
    Location
    Washington State
    Posts
    593

    Default

    Quote Originally Posted by Joe mcmanus View Post
    So I just bought this car few weeks ago, now all of a sudden I have no tachometer, light buckets won't come up and if I manually make them the lights don't work but if I put on hight beam you see the lights flash on for a second. There is a flutter with the interior lighting and with the buttons beside mycluster. So I just wondering if this could all be linked or separate issues. The battery was replaced the day I got it by previous owner. Any help appreciated

    Start with the basics, clean and tight battery cables and have the battery load tested no matter how new it is, new batteries can be bad. You need to prove that the battery is good before trusting any other electrical diagnosis procedures.
    20+ years ASE and Honda Master Tech

    1998 black 6 spd convertible

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •