Results 1 to 6 of 6

Thread: Help with C5 not starting

  1. #1
    Join Date
    Jan 2020
    Location
    Fleming Ga
    Posts
    3

    Default Help with C5 not starting

    I have a 2001 LS1 Auto trans corvette. Not starting. Replaced ignition switch (amazon) and battery is new. Started fine for about a month and then all of the sudden...Nothing!!! All dash and power seems to work just fine when turned on but no power going to starter now...Help......Can anyone maybe direst me to what they may have had to do to theirs. I want to do as much as I can to learn a little more about these but havn't had this but around 6 months and am still old school on working on cars....Love the C5 but really frustrating right now...Thanks

  2. #2
    Join Date
    Dec 2011
    Location
    New Haven, Ct
    Posts
    924

    Default

    HI there,

    The first thing you can do is check your battery cables to assure there is no oxidation on the cables themselves where they contact the battery terminals. Torque the bolts to 11 ft lbs.

    Do you notice the security light on when you attempt to start the vehicle? if it is, that tells you that the body control module is NOT seeing something that it wants. If not, attempt to shift the vehicle into NEUTRAL before you start it, does it then start?? If so, you have an issue with the neutral safety switch on the side of the automatic transmission.

    Then, you stated you replaced the ignition switch, was it a GM unit or was it aftermarket?? GM units are MUCH MUCH more robust and last much longer. I have had customers with aftermarket get bad ones out of the box. When you did the ignition switch, did you replace the key lock cylinder at the same time????

    Keep us up to date and we will help you as we can. AND WELCOME!!!!!

    Allthebest, Paul
    Last edited by c4c5specialist; 01-15-2020 at 04:37 PM. Reason: Additional information
    GM World Class Certified Service Technician.
    Like us on Facebook: www.facebook.com/corvettemechanic
    Twitter: www.twitter.com/GMvettemechanic

  3. #3
    Join Date
    Jan 2020
    Location
    Fleming Ga
    Posts
    3

    Default

    Quote Originally Posted by claygo View Post
    I have a 2001 LS1 Auto trans corvette. Not starting. Replaced ignition switch (amazon) and battery is new. Started fine for about a month and then all of the sudden...Nothing!!! All dash and power seems to work just fine when turned on but no power going to starter now...Help......Can anyone maybe direst me to what they may have had to do to theirs. I want to do as much as I can to learn a little more about these but havn't had this but around 6 months and am still old school on working on cars....Love the C5 but really frustrating right now...Thanks
    Thank you so much for your reply. I have checked everything you suggested. I replaced the ign switch about 2 months ago. Ordered off Amazon. Like i said it worked for about a month and then a month ago .......Nothing (to this day) I believe it was in a delco box but dont remember positively. I thought of that and was gonna just order another one from auto zone as it gives choice of 2. One seems to be Delco. I have NOT replaced the key tumblers ( I unerstand I have to go to a Chev dealer to get and do this)...Should I go ahead and at least order the ign switch and if to no avail go with new lock assembly from dealer.....thanks for your support.

  4. #4
    Join Date
    Dec 2011
    Location
    New Haven, Ct
    Posts
    924

    Default

    HI there,

    My suggestion, being that you already know how to remove the ignition switch, I would order the lock cylinder from your local GM dealership, have them code it to your keys and then install them all.

    Do you know how to retrieve diagnostic trouble codes? If not, please see our sticky post at the top of the page and utilize that process.

    We need codes from the 10-PCM 40- BCM to accurately determine our next course of action. Please use this process and let me know.

    Allthebest, Paul
    GM World Class Certified Service Technician.
    Like us on Facebook: www.facebook.com/corvettemechanic
    Twitter: www.twitter.com/GMvettemechanic

  5. #5
    Join Date
    Jan 2020
    Location
    Fleming Ga
    Posts
    3

    Default

    Quote Originally Posted by c4c5specialist View Post
    HI there,

    My suggestion, being that you already know how to remove the ignition switch, I would order the lock cylinder from your local GM dealership, have them code it to your keys and then install them all.

    Do you know how to retrieve diagnostic trouble codes? If not, please see our sticky post at the top of the page and utilize that process.

    We need codes from the 10-PCM 40- BCM to accurately determine our next course of action. Please use this process and let me know.

    Allthebest, Paul
    I'll get the 2 installed and see where I'm at . Will let you know in a week or so how it turned out...Thanks so much for the help.....Clay

  6. #6
    Join Date
    Jul 2016
    Posts
    14

    Default

    On mine I went straight to the starter relay for testing and found the relay itself to be at fault

    Sent from my SM-T530NU using Tapatalk

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •