Results 1 to 10 of 10

Thread: Radio stuck no nav or controls

  1. #1
    Join Date
    Jan 2020
    Posts
    4

    Default Radio stuck no nav or controls

    Hello,
    We recently acquired a 2008 Corvette that has an issue with radio/nav system. The radio plays, but is stuck on one channel and we have no volume controls, also the navigation screen is blank. We found there is a Technical Bulletin 09-08-44-019, that supposedly solves this issue. We have contacted our local dealership and they don't seem to have the disc to fix this issue. Does anyone have a disc, or link to download so that we can fix the known issue?

  2. #2
    Join Date
    Jul 2008
    Location
    Ontario, Calif.
    Posts
    3,011

    Default

    Right here on the site Paul has a fix that might help you.

    https://www.thecorvettemechanic.com/...tion-fix-for-a
    2015 Stingray Z51 w/ Magnetic Ride Control & 8-speed Automatic


  3. #3
    Join Date
    Jan 2020
    Posts
    4

    Default

    Quote Originally Posted by Poltergeist View Post
    Right here on the site Paul has a fix that might help you.

    https://www.thecorvettemechanic.com/...tion-fix-for-a
    Thanks, we saw this, but it states to fix clock issue...our issue is more than a clock issue. We plan to try the fix you mention, but wanted to know if anyone had the fix for the larger issue.
    Much appreciated!

  4. #4

    Default

    HI there,

    I would recommend that you start by disconnecting your negative battery cable for 15 mins and reconnect it.

    Then see what happens with your radio functions.

    Please keep us posted, Paul
    GM World Class Certified Service Technician.
    Like us on Facebook: www.facebook.com/corvettemechanic
    Twitter: www.twitter.com/GMvettemechanic

  5. #5
    Join Date
    Jan 2020
    Posts
    4

    Default

    We will try that. Stay tuned.

  6. #6
    Join Date
    Jan 2020
    Posts
    4

    Default

    Battery disconnect and zip disc download did not work. Any other suggestions?

  7. #7

    Default

    HI there,

    Unfortunately no.

    I have experienced that some do not take the uploaded file.

    I do not know why this is, however, usually an exchanged unit from an ACDelco electronics service center is the only way to repair it that I know of.

    Allthebest, Paul
    GM World Class Certified Service Technician.
    Like us on Facebook: www.facebook.com/corvettemechanic
    Twitter: www.twitter.com/GMvettemechanic

  8. #8
    Join Date
    May 2020
    Location
    State College PA
    Posts
    2

    Default

    Hi Guys,
    I have a 2013 Grand Sport and just experienced the blank screen, radio with volume, not able to control with any button, can't open flip down to access CD slot. Any thoughts greatly appreciated.

    Thanks,

    Jim

    Update:
    Pulled the negative lead for probably 15 minutes and reattached. It's magic! Radio/Nav screen working like new.....
    Last edited by JimC6; 05-14-2020 at 10:10 AM. Reason: UPDATE

  9. #9

    Default

    HI there,

    This would be separate from the blank clock issue or navigation issue.

    Please disconnect your negative battery cable for 10 mins to reset the system.

    Please let us know how you make out.

    Allthebest, Paul
    GM World Class Certified Service Technician.
    Like us on Facebook: www.facebook.com/corvettemechanic
    Twitter: www.twitter.com/GMvettemechanic

  10. #10
    Join Date
    May 2020
    Location
    State College PA
    Posts
    2

    Default

    Thanks, I did just that and it works for now.

    Appreciate it,

    Jim

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •