Results 1 to 6 of 6

Thread: lots of questions!!! 02 C5 Coupe

  1. #1
    Join Date
    Jun 2017
    Location
    Bandera, Texas
    Posts
    1

    Default lots of questions!!! 02 C5 Coupe

    I took ownership of the car from my father 3 years ago who is original owner and car has had no previous major issues, car has 110,000 miles on it.

    simple issue #1 - the elbow connector that comes our of firewall in front of windshield for wiper fluid is broke and I cant find one anywhere??

    now the fun stuff - Traction control system sometimes when I start car it says its warming up and sometimes it doesn't? Ill be driving along and all of a sudden it comes on??

    cigarrete lighter and outlet in console not working - checked fuse and all is good there, why are both not working and fuse good?

    Other small issues to mess with due to normal wear and tear
    seat controls and side panels of seats broken from my fat butt climbing in and out
    radio gets crappy / weak signal and lots of static. don't want to go after market as I would like to keep car original


    That's allot for a first time poster I know but I finally decided to start looking around for help and get these issues fixed.

    Thanks!

  2. #2
    Join Date
    Dec 2011
    Location
    Clever, MO
    Posts
    177

    Default

    I've used Dino for many little C5 parts, both used and some new. Give him a call.
    https://www.corvettesalvage.com/

    Some issues may be caused by worn contacts in the ignition module that the key tumble fits into. It's an easy cheap fix for a DIY'er. See my sticky about it at the top of this C5 Form page. It may help you.

    This is another good vendor:
    http://www.vettenuts.net/

    Do google searches for solutions too.....type in your specific issue and see what pops up. There are a lot of youtube vids available.

    Good luck
    Last edited by Fixvet; 06-24-2017 at 08:36 AM.

    Dennis "Fix" Fixsen dba FixVet Detailing Services, Clever, MO
    1998 Black over Torch Red Coupe, A4, F45, 3.15 rear, HP Tune, CAI, Vararam Velocity Stack, Z06 TI Catbacks, drilled/slotted rotors....VFW Life Member, VN Vet 70-71, 4thINF & 101stABN

  3. #3
    Join Date
    Dec 2011
    Location
    Southern California
    Posts
    817

    Default

    Quote Originally Posted by Br1006 View Post
    I took ownership of the car from my father 3 years ago who is original owner and car has had no previous major issues, car has 110,000 miles on it.

    simple issue #1 - the elbow connector that comes our of firewall in front of windshield for wiper fluid is broke and I cant find one anywhere??

    now the fun stuff - Traction control system sometimes when I start car it says its warming up and sometimes it doesn't? Ill be driving along and all of a sudden it comes on??

    cigarrete lighter and outlet in console not working - checked fuse and all is good there, why are both not working and fuse good?

    Other small issues to mess with due to normal wear and tear
    seat controls and side panels of seats broken from my fat butt climbing in and out
    radio gets crappy / weak signal and lots of static. don't want to go after market as I would like to keep car original


    That's allot for a first time poster I know but I finally decided to start looking around for help and get these issues fixed.

    Thanks!
    For #1 you mean the little 90 deg. black plastic part for fluid? If so it's a standard part a big napa should have (or have the guy order it if not in stock). Please don't say that has to be gm original.



    TC warming up msg. is normal once in a while, if it happens every day or several times a day, probably the steering wheel position sensor. R&R.

    If the wires to the outlet are disconnected somewhere along the line the fuse will NOT blow. Basic elec. circuit troubleshoot.

    You should probably watch some/all my yt videos, a lot of guys have told me they help. See below.



    Learn to pull codes, they are your friend.
    Last edited by froggy47; 06-24-2017 at 02:12 PM.
    2013 Zo6

    2004 Z06/Z16 Stock motor, very modified suspension

    1996 Black/gray LT4 Coupe (sold)

    2007 328i (traded), 2004 IS300, 1995 M3 (sold), Chevy & Ford & Lexus SUV's.

    '06,'09,'10,'11,'12,'13,'16,'17 SCCA Regional Solo Champion

    Visit my DIY video channel for tips. Click below.

    http://www.youtube.com/user/1947froggy?feature=guide

  4. #4
    Join Date
    May 2017
    Location
    Sacramento, CA
    Posts
    12

    Default

    My seat controls were busted off as well. Comes from getting in and out of your car, and the seat foam breaking down. Replacing the foam is not a difficult task, and there are some very good write ups on how to do it across the forums. Don't forget to put the indoor/outdoor carpet between the new foam and the bottom seat wires to keep them from cutting into your new foam

  5. #5
    Join Date
    Apr 2018
    Posts
    10

    Default

    Quote Originally Posted by markmark View Post
    My seat controls were busted off as well. Comes from getting in and out of your car, and the seat foam breaking down. Replacing the foam is not a difficult task, and there are some very good write ups on how to do it across the forums. Don't forget to put the indoor/outdoor carpet between the new foam and the bottom seat wires to keep them from cutting into your new foam

    Have you ever fixed the seat controls? We'll be working on the Corvette right after we finished installing the rack and tonneau cover for the kayak mount on the truck. Found some good write up about seat foam. Hoping the seat controls can be fixed.

  6. #6
    Join Date
    May 2017
    Location
    Sacramento, CA
    Posts
    12

    Default

    Quote Originally Posted by Gefroy View Post
    Have you ever fixed the seat controls? We'll be working on the Corvette right after we finished installing the rack and tonneau cover for the kayak mount on the truck. Found some good write up about seat foam. Hoping the seat controls can be fixed.
    I personally never had to repait the actual controls. The controls slong with the bezel had broken off my seat for reasons explained. I’m sure that someone out there has had them fully apart for some reason or two and prolly has a write up on it. Good luck with the rest of your project.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •